Error logs - 6.1.6

Forum to discuss Optimizations and Implementation of threads connections for SMTP

Error logs - 6.1.6

Postby myshop » Fri Apr 29, 2016 7:00 pm

I receive these log entries..

Invalid argument supplied for foreach() Internal Apr 29 2016 22:55:37
Invalid argument supplied for foreach() in /home/xxx/public_html/admin/addons/installer/api/class.commandline.php at 66
File Line Function
/home/xxx/public_html/admin/addons/installer/api/class.commandline.php 66 HandlePHPErrors
/home/xxx/public_html/admin/addons/installer/api/installer.php 932 CommandLine::parseArgs
/home/xxx/public_html/admin/addons/multithread/api/multithread.php 32 Installer_API->apply_patches
/home/xxx/public_html/admin/addons/multithread/multithread.php 232 require_once
/home/xxx/public_html/admin/addons/interspire_addons.php 1408 Addons_multithread->GetApi
/home/xxx/public_html/admin/functions/schedule.php 262 Interspire_Addons->Process
/home/xxx/public_html/admin/functions/schedule.php 144 Schedule->ManageSchedules
/home/xxx/public_html/admin/com/init.php 543 Schedule->Process
/home/xxx/public_html/admin/index.php 81 require_once


and also this:

array_shift() expects parameter 1 to be array, null given Internal Apr 29 2016 22:55:37
array_shift() expects parameter 1 to be array, null given in /home/xxx/public_html/admin/addons/installer/api/class.commandline.php at 63
File Line Function
/home/xxx/public_html/admin/addons/installer/api/class.commandline.php 63 HandlePHPErrors
/home/xxx/public_html/admin/addons/installer/api/installer.php 932 CommandLine::parseArgs
/home/xxx/public_html/admin/addons/multithread/api/multithread.php 32 Installer_API->apply_patches
/home/xxx/public_html/admin/addons/multithread/multithread.php 232 require_once
/home/xxx/public_html/admin/addons/interspire_addons.php 1408 Addons_multithread->GetApi
/home/xxx/public_html/admin/functions/schedule.php 262 Interspire_Addons->Process
/home/xxx/public_html/admin/functions/schedule.php 144 Schedule->ManageSchedules
/home/xxx/public_html/admin/com/init.php 543 Schedule->Process
/home/xxx/public_html/admin/index.php 81 require_once

Can you please advise what these are and if we can fix?
myshop
 
Posts: 2
Joined: Fri Apr 29, 2016 6:54 pm

Re: Error logs - 6.1.6

Postby mmm » Sat May 07, 2016 12:49 am

try this:
#1 finish campaigns/do not start new ones
#2 disable all addons one by one
#3 uninstall addon installer
#4 reinstall addon installer
#5 enable all addons one by one
#6 use app again
#7 report back how that works
mmm
 
Posts: 131
Joined: Sat Apr 11, 2015 4:36 pm


Return to Multithreads

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest